▷ Métricas de Erros no Excel – Competição do Kaggle

Olá seja bem vindo ao meu artigo

Com o aumento das competições de Machine Learning como o famoso Kaggle e inspirado no artigo abaixo

https://www.sciencedirect.com/science/article/abs/pii/S0169207020301114

Segue novas medidas de métricas para a validação dos modelos de previsão.

Recomendo muito a leitura do artigo acima, onde demonstra as competições entre os modelos clássicos versus os modelos de Machine Learning e Redes Neurais e quais foram os vencedores.

O intuito deste artigo será mostrar as novas métricas de erros que é utilizado nas competições do Kaggle M4 e M5. Vamos a elas

WMAE - Weighted Mean Absolute Error | Erro médio absoluto ponderado

Utilizado na base Walmart Store Sales, o cálculo para este erro tem a seguinte fórmula abaixo

Segue a fórmula na célula G4

=SOMA(ABS(ÍNDICE(B4:B15-C4:C15;0))*D4:D15)/SOMA(D4:D15)

ou em inglês

=SUM(ABS(INDEX(B4:B15-C4:C15;0))*D4:D15)/SUM(D4:D15)

O interessante deste erro que ele multiplica um peso unitário e depois faz a divisão do somatório do peso.

RMSLE - Root Mean Squared Logarithmic Error | Raiz do Erro logarítmico médio quadrático

Utilizado na base Walmart Stormy Weather e Recruit Restaurant, o cálculo para este erro tem a seguinte fórmula abaixo

Segue a fórmula na célula G5

=RAIZ(MÉDIA(ÍNDICE((LOG(C4:C15+1)-LOG(B4:B15+1))^2;0)))

ou em inglês

=SQRT(AVERAGE(INDEX((LOG(C4:C15+1)-LOG(B4:B15+1))^2;0)))

RMSPE - Root Mean Square Percentage Error | Raiz do Erro Percentual Médio Quadrático

Utilizado na base Rossmann Store Sales, o cálculo para este erro tem a seguinte fórmula abaixo

Segue a fórmula na célula G6

=RAIZ(MÉDIA(ÍNDICE(((B4:B15-C4:C15)/B4:B15)^2;0)))

ou em inglês

=SQRT(AVERAGE(INDEX(((B4:B15-C4:C15)/B4:B15)^2;0)))

SMAPE - Symmetric Mean Absolute Percentage Error | Erro percentual médio simétrico absoluto

Utilizado na base Wikipedia Web Traffic, esta métrica já foi descrita em outro artigo publicado aqui neste blog, clique aqui.

Segue a fórmula na célula G7

=MÉDIA(ÍNDICE(2*ABS(B4:B15-C4:C15)/(ABS(B4:B15)+ABS(C4:C15));0))

ou em inglês

=AVERAGE(INDEX(2*ABS(B4:B15-C4:C15)/(ABS(B4:B15)+ABS(C4:C15));0))

NWRMSLE - Normalized Weighted Root Mean Squared Logarithmic Error | Erro logarítmico médio quadrático médio ponderado normalizado

Utilizado na base Corporación Favorita, o cálculo para este erro tem a seguinte fórmula abaixo

Segue a fórmula na célula G8

=RAIZ(SOMA(ÍNDICE(D4:D15*(LOG(C4:C15+1)-LOG(B4:B15+1))^2;0))/SOMA(D4:D15))

ou em inglês

=SQRT(SUM(INDEX(D4:D15*(LOG(C4:C15+1)-LOG(B4:B15+1))^2;0))/SUM(D4:D15))

Espero que tenha gostado desse artigo!

Muito Obrigado Prof. Dr. Leandro dos Santos Coelho (meu querido orientador) pelo artigo, pelas incansáveis orientações, obrigadão de coração!

Caso tenha alguma sugestão de outra técnica ou melhoria do conteúdo acima, poste aqui nos comentários.

Se gostou, curta e compartilhe este artigo para que todos saibam o que é possível fazer dentro do MS Excel.

E ja conhece o meu novo curso online de Excel?

Abraços a todos e até o próximo artigo!

Fabio BALDINI

Frase do Dia: "Somente os que ousam errar muito podem realizar muito." Autor: John F. Kennedy

Deixe um comentário

O seu endereço de e-mail não será publicado.