▷ AHP-Gaussiano no Excel

Olá seja bem vindo ao meu mais novo artigo

O método AHP-GAUSSIAN- Analytic Hierarchy Process (Processo de Hierarquia Analítica - Gaussiana), foi publicado por Santos, Gomes e Costa (2021) no International Journal of the Analytic Hierarchy Process (IJAHP), visa propor uma nova abordagem para o método AHP, sem a dependência da matriz de avaliação entre os critérios, sendo que para os cálculos deve-se utilizar média e o desvio padrão para a obtenção do ranking das alternativas. Este método tem os seguintes atributos:

• Pertence aos métodos compensatórios;
• Os atributos são independentes;
• Os atributos qualitativos são convertidos em atributos quantitativos;

Mas antes queria agradecer a imensa ajuda no entendimento do passo a passo deste método do Comandante Prof. Dr. Marcos dos Santos, pela sempre ajuda em todos os modelos desenvolvidos, muito obrigado Professor de coração!

No exemplo abaixo será demonstrado a aplicação do artigo com 9 critérios e 3 alternativas;

Vamos ao método AHP-GAUSSIANO passo a passo;

1° Etapa

Definição dos critérios de Maximização ou Minimização;

2° Etapa

Criação da Matriz Normalizada Método AHP-GAUSSIANO

Segue a fórmula na célula C11

=SE(C$3="MAX";C5/SOMA(C$5:C$7);(1/C5)/(SOMA(ÍNDICE(1/C$5:C$7;0))))

ou em inglês

=IF(C$3="MAX";C5/SUM(C$5:C$7);(1/C5)/(SUM(INDEX(1/C$5:C$7;0))))

3° Etapa

Calcular a Média, Desvio Padrão e com isso Calcular o Fator Gaussiano e após, normalizar o Fator Gaussiano

Segue a fórmula da Média iniciada na célula C15

=MÉDIA(C11:C13)

ou em inglês

=AVERAGE(C11:C13)

Para o resultado do Desvio Padrão, segue a fórmula iniciando na célula C16

=DESVPAD(C11:C13)

ou em inglês

=STDEV(C11:C13)

Para a obtenção do Fator Gaussiano deve dividir o desvio padrão pela média, que segue na célula C17

=DESVPAD(C11:C13)/MÉDIA(C11:C13)

ou em inglês

=STDEV(C11:C13)/AVERAGE(C11:C13)

4° Etapa

Criação Análise de sensibilidade do ranking de alternativas do Método AHP-GAUSSIANO

O cálculo da Análise de Sensibilidade do Ranking, segue a célula N11

=SOMARPRODUTO(C11:K11;$C$19:$K$19)

ou em inglês

=SUMPRODUCT(C11:K11;$C$19:$K$19)

E o Raking Final que segue na célula P11

=ORDEM(N11;$N$11:$N$13)

ou em inglês

=RANK(N11;$N$11:$N$13)

Segue o método AHP-GAUSSIANO Dinâmico!

Espero que tenha gostado desse artigo!

Novamente gostaria agradecer imensamente ajuda do Comandante Prof. Dr. Marcos dos Santos para este método, muito obrigado de coração Professor!

Caso tenha alguma sugestão de outra técnica ou melhoria do conteúdo acima, poste aqui nos comentários.

Se gostou, curta e compartilhe este artigo para que todos saibam o que é possível fazer dentro do MS Excel.

Venha fazer o melhor curso EAD de Excel comigo! Clique e compare!

Abraços a todos e até o próximo artigo!

Fabio BALDINI

Frase do Dia: "Quando uma criatura humana desperta para um grande sonho e sobre ele lança toda a força de sua alma, o universo passa a conspirar a seu favor." Autor: Johann Wolfgang von Goethe

Deixe um comentário

O seu endereço de e-mail não será publicado.