▷ TODIM no Excel – Tomada de Decisão Interativa Multicritério

Olá seja bem vindo ao meu mais novo artigo

O método TODIM - Tomada de Decisão Interativa Multicritério, foi introduzido por Gomes e Lima em 1992. A idéia principal é medir o grau de dominância de cada alternativa sobre a outra alternativas usando o valor geral. O novo método TODIM possui as seguintes características:

• Este método pertence aos métodos compensatórios;
• Os atributos são independentes uns dos outros;
• Os atributos qualitativos devem ser convertidos em atributos quantitativos.

No exemplo abaixo será demonstrado uma aplicação com 5 critérios e 3 alternativas;

Vamos ao método TODIM passo a passo;

1° Etapa

Definição dos critérios de Maximização ou Minimização e seus pesos;

2° Etapa

Criação da Matriz Normalizada

Segue a fórmula iniciando na Célula D12

=SE(D$4="MAX";D6/SOMA(D$6:D$8);(1/D6)/SOMA(ÍNDICE(1/D$6:D$8;0)))

ou em inglês

=IF(D$4="MAX";D6/SUM(D$6:D$8);(1/D6)/SUM(INDEX(1/D$6:D$8;0)))

3° Etapa

Nesta etapa do método TODIM deve realizar a comparação entre as alternativas, que segue abaixo.

Segue a fórmula na célula D17

=SEERRO(RAIZ(((D$3/MÁXIMO($D$3:$H$3))*(DESLOC(D$11;CORRESP(
$B17;$C$12:$C$14;0);0)-DESLOC(D$11;CORRESP($C17;$C$12:$C$14;0)
;0)))/SOMA(ÍNDICE($D$3:$H$3/MÁXIMO($D$3:$H$3);0)));-RAIZ((SOMA(
ÍNDICE($D$3:$H$3/MÁXIMO($D$3:$H$3);0))*ABS(DESLOC(D$11;CORRESP(
$B17;$C$12:$C$14;0);0)-DESLOC(D$11;CORRESP($C17;$C$12:$C$14;0)
;0))/(D$3/MÁXIMO($D$3:$H$3)))))

ou em inglês

=IFERROR(SQRT(((D$3/MAX($D$3:$H$3))*(OFFSET(D$11;MATCH(
$B17;$C$12:$C$14;0);0)-OFFSET(D$11;MATCH($C17;$C$12:$C$14;0)
;0)))/SUM(INDEX($D$3:$H$3/MAX($D$3:$H$3);0)));-SQRT((SUM(
INDEX($D$3:$H$3/MAX($D$3:$H$3);0))*ABS(OFFSET(D$11;MATCH(
$B17;$C$12:$C$14;0);0)-OFFSET(D$11;MATCH($C17;$C$12:$C$14;0)
;0))/(D$3/MAX($D$3:$H$3)))))

3° Etapa

Com os cálculos entre as alternativas, deve realizar as somas das comparações entre as alternativas e realizar o ranking do Método TODIM

Segue a fórmula na célula D31

=SOMA(D17:H18)

ou em inglês

=SUM(D17:H18)

O Ranking final do Método TODIM, segue a fórmula na célula E31

=ORDEM(D31;$D$31:$D$33)

ou em inglês

=RANK(D31;$D$31:$D$33)

Segue o método TODIM Dinâmico!

Espero que tenha gostado desse artigo!

Caso tenha alguma sugestão de outra técnica ou melhoria do conteúdo acima, poste aqui nos comentários.

Se gostou, curta e compartilhe este artigo para que todos saibam o que é possível fazer dentro do MS Excel.

Venha fazer o melhor curso EAD de Excel comigo! Clique e compare!

Abraços a todos e até o próximo artigo!

Fabio BALDINI

Frase do Dia: "Mesmo que já tenhas feito uma longa caminhada, há sempre um novo caminho a fazer" Autor: Santo Agostinho

Deixe um comentário

O seu endereço de e-mail não será publicado.