▷ MOOSRA no Excel – Multi-Objective Optimisation on the Basis of Simple Ratio Analysis

Olá seja bem vindo ao meu mais novo artigo

O método MOOSRA - Multi-Objective Optimisation on the Basis of Simple Ratio Analysis (Otimização multi-objetivo com base na análise de razão simples) foi introduzida por Das, Sarkar e Ray em 2012. Este método é muito próximo ao postado aqui sobre o MOORA, mas com suas particularidades. O método MOOSRA possui as seguintes características:

• Pertence aos métodos compensatórios;
• Os atributos são independentes;
• Os atributos qualitativos são convertidos em atributos quantitativos;
• Simplicidade na execução do método.

Segue o artigo com a referência citada do método MOOSRA

https://ijret.org/volumes/2014v03/i15/IJRET20140315105.pdf

No exemplo abaixo será demonstrado uma aplicação com 10 critérios e 3 alternativas;

Vamos ao método MOOSRA passo a passo;

1° Etapa

Definição dos critérios de Maximização ou Minimização e seus pesos;

2° Etapa

Criação da Matriz Normalizada e Ponderada do Método MOOSRA

Segue a fórmula na célula C12

=C6/RAIZ(SOMAQUAD(C$6:C$8))*C$3

ou em inglês

=C6/SQRT(SUMSQ(C$6:C$8))*C$3

Fator Y, segue a fórmula inciando na célula N12

=SOMASES($C12:$L12;$C$4:$L$4;"MAX")/SOMSASES($C12:$L12;$C$4:$L$4;"MIN")

ou em inglês

=SUMIFS($C12:$L12;$C$4:$L$4;"MAX")/SUMIFS($C12:$L12;$C$4:$L$4;"MIN")

O Ranking final do Método MOOSRA, segue a fórmula na célula P12

=ORDEM(N12;$N$12:$N$14)

ou em inglês

=RANK(N12;$N$12:$N$14)

Segue o método MOOSRA Dinâmico!

Espero que tenha gostado desse artigo!

Caso tenha alguma sugestão de outra técnica ou melhoria do conteúdo acima, poste aqui nos comentários.

Se gostou, curta e compartilhe este artigo para que todos saibam o que é possível fazer dentro do MS Excel.

Venha fazer o melhor curso EAD de Excel comigo! Clique e compare!

Abraços a todos e até o próximo artigo!

Fabio BALDINI

Frase do Dia: "Não se preocupe com o fracasso. Você só precisa acertar uma vez." Autor: Drew Houston, co-fundador do Dropbox

Deixe um comentário

O seu endereço de e-mail não será publicado.