Conversão do Primavera para MS Project usando o MS Excel

Olá seja bem vindo ao meu novo artigo!

Neste artigo irei abordar um problema na exportação dos dados do Primavera (software de gerenciamento de projetos) para o MS Excel.

Vamos analisar sua exportação abaixo:

Verificada sua exportação, não fica clara e nem objetiva, analisar os dados para tomar uma decisão.

Quando realizado a exportação dos dados de um projeto do MS Project para o MS Excel, pode verificar que as informações seguem um padrão uniforme dos dados do projeto, tanto para atividades pais-fillhas quanto para as datas.

Para realizar esta conversão deverá adicionar algumas colunas onde o formato ficará de maneira adequada e correta. Conforme demonstrado abaixo:

Vamos para as colunas de Conversão

Coluna H - Descrição da Atividade, segue a fórmula abaixo:

=SUBSTITUIR(ESQUERDA(A2;NÚM.CARACT(A2)-NÚM.CARACT(ARRUMAR(A2))-NÚM.CARACT(ARRUMAR(ESQUERDA(A2;NÚM.CARACT(A2)-NÚM.CARACT(ARRUMAR(A2))))));"  ";"   ")&IF(B2="";ARRUMAR(A2);ARRUMAR(B2))

ou em inglês

=SUBSTITUTE(LEFT(A2;LEN(A2)-LEN(TRIM(A2))-LEN(TRIM(LEFT(A2;LEN(A2)-LEN(TRIM(A2))))));"  ";"   ")&IF(B2="";TRIM(A2);TRIM(B2))

Quando exportado os dados do MS Project para o MS Excel, para cada nível da identação da atividade, o MS Project adiciona três espaços, já no Primavera ele adiciona somente dois espaços, onde esta fórmula acima faz o ajuste correto.

Coluna I - Duração e Budgeted, é só copiar a coluna

=C2 | =F2

Coluna J - Início

=SE(D2="";SUBSTITUIR(SUBSTITUIR(E2;"*";"");" A";"")*1;SUBSTITUIR(SUBSTITUIR(D2;"*";"");" A";"")*1)

ou em inglês

=IF(D2="";SUBSTITUTE(SUBSTITUTE(E2;"*";"");" A";"")*1;SUBSTITUTE(SUBSTITUTE(D2;"*";"");" A";"")*1)

Coluna K - Término

=SE(E2="";SUBSTITUIR(SUBSTITUIR(D2;"*";"");" A";"")*1;SUBSTITUIR(SUBSTITUIR(E2;"*";"");" A";"")*1)

ou em inglês

=IF(E2="";SUBSTITUTE(SUBSTITUTE(D2;"*";"");" A";"")*1;SUBSTITUTE(SUBSTITUTE(E2;"*";"");" A";"")*1)

Para o Início e para o Término o Primavera só preenche em uma coluna, quando é uma atividade marco, sendo necessário fazer todo o ajuste para repetir as datas de modo que fique igual ao MS Project, realizando análises futuras e comparações.

Pronto! A conversão está feita!

Espero que tenha gostado desse artigo!

Caso tenha alguma sugestão de outra técnica, poste aqui nos comentários.

Se gostou, curta e compartilhe este artigo para que todos saibam o que é possível fazer dentro do Excel.

Venha dominar o Excel e desenvolver estratégias secretas como os dos diversos artigos! Estão abertas as Inscrições dos meus Cursos de Excel! Com um método totalmente inovador e didático! Clique aqui para saber mais!

Abraços a todos e até o próximo artigo!

Fabio BALDINI

Frase do Dia: "Não crie limites para si mesmo. Você deve ir tão longe quanto sua mente permitir. O que você mais quer poder ser conquistado." Autora: Mary Kay

OBS: Quero agradecer imensamente ao Grande Mestre e Amigão Alessandro Trovato pelas eternas revisões dos artigos para que sempre fique esmero!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *